Biztalk Documenter does nothing!

Mar 25, 2010 at 12:19 PM

Hi,

We have a 64 bit biztalk 2006 R2 farm on 2 Windows 2003 R2 machines, with SQL 2005 on a third machine. I wanted to create a Biztalk configuration document, using Biztalk Documenter. So I installed it on one Biztalk machine and ran it! But no result..

So I installed HHC 1.3 and tried again. But again it just returned to the prompt. No errors reported or what ever....

So I looked at the Microsoft.Services.Tools.BiztalkDocumenter.exe.config and found out that there was some configuration left. 
I set the correct helpcompilerlocation, Tracelevel to 7, correct Tracelogdirectory, correct dependentassembly codebase and removed the remarkers. And ran it again. Even though no result, just the prompt again.

I even started Procmon and logged the very short run of the documenter. No erors are logged.

So why can't I run the documenter succesfully?

Greetings, Sebastian.

Mar 28, 2010 at 10:43 PM

Hi Sebastian,

I think it maybe due to the 64 bit support issue. A few others have reported this problem. I will upload a fix as soon as possible. Re: the tracing, I agree the output is non existent and i have tried to fix it but no success so far. I think it probably needs a complete rewrite in that area.

cheers,

benjy

Apr 1, 2010 at 10:30 AM

Hi Benjy,

Do You have enough information to fix it? If You need more, I can try to produce more if You tell me how.

Greetings,

     Sebastian.

Apr 1, 2010 at 11:08 PM

Hi Sebastian,

I tried running it on a new 64 bit image just a couple of days ago, it seemed to work fine, although there could be some version mismatches going on. I'll take out sometime this weekend to look over it again and get back to you.

Regards,

Benjy

May 26, 2010 at 9:28 AM

Hi,

V3.4 has now been released so I hope this problem has gone away. Please check and let me know.

Regards,

Benjy