The current user 'domain/username' failed to connect to the management database

Feb 7, 2008 at 12:09 PM

I'm getting the following error when I ran documenter.

The current user 'domain/username' failed to connect to the management database.

The current user is a 'sysadmin' on the BizTalk database server also the local admin on the BizTalk Application server and the database server as well. When I connected to the sql server in Enterprise studio using this windows account, no problems.

We have multi-server BizTalk environment with one BizTalk 2006 app server, and a 2 node SQL Server 2005 cluster that hosts BizTalk databases.

I've checked all the eventlogs, sql logs etc. but could not find any issues. It's just a simple connectivity issue... Any help would be greatly


Jun 18, 2010 at 5:55 PM

I am getting the same error.  The user has execute/read/write privaleges on the mgmt database and the database is local.  Any luck with this issue?  

Jun 18, 2010 at 10:28 PM


As posted on the other thread, please check if the logged on user is a member of SSO Administrators or SSO Affiliate Administrators. If the user is already a member and you are still getting the error, then you could try a simple test to instantiate a BtsCatalogExplorer object (using Microsoft.BizTalk.ExplorerOM.dll) . If that works, please let me know and I will try to debug further or increase the scope of the exception logging so that it produces more detailed output.

You can find an example of ExplorerOM that works with send port info at the following link